AWS Outage affecting Placements.io

Incident Report for placements.io

Resolved

The incident is resolved in upstream service providers.
Posted Oct 20, 2025 - 22:56 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 21:57 UTC

Monitoring

Our primary database is recovered and fully operational. Updates to the platform can resume. We continue to monitor all areas of the application and will give the all clear once we are confident the issue is permanently resolved - and once AWS has given the all clear.
Posted Oct 20, 2025 - 20:27 UTC

Update

AWS has deployed their fix and continues to see improvements. We are working with our infrastructure provider to get our primary database back to fully operational - it remains in readonly mode for now. There is a backlog of recoveries on ongoing, and it's unclear how long it will take to process ours.

AWS incident status is available here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 20:14 UTC

Identified

Our database continues to be in a readonly state.

Amazon has deployed mitigations that are starting to improve connectivity issues. We continue to monitor on our side and will update when we see some improvements.

The root incident status is here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 18:52 UTC

Investigating

Upstream issues with AWS are affecting Placements.io operations. We are seeing intermittent issues, especially with write operations.

AWS incident status is available here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 16:36 UTC
This incident affected: api.placements.io and app.placements.io.