Placements is experiencing issues with our primary infrastructure provider
Incident Report for placements.io
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:19 UTC
Monitoring
Cloudflare has fixed the issue and is monitoring the result.
Posted Jun 21, 2022 - 07:24 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 21, 2022 - 07:03 UTC
Update
Some Placements users might experience degraded performance due to a downstream disruption in Cloudflare, a network protection service used by Placements.

The status of the incident can be found here:
https://www.cloudflarestatus.com/

We will update this issue once resolved.
Posted Jun 21, 2022 - 06:54 UTC
Identified
Placements is experiencing issues with our primary infrastructure provider
Posted Jun 21, 2022 - 06:52 UTC
This incident affected: api.placements.io, app.placements.io, and www.placements.io.